A Windows XP help forum. PCbanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » PCbanter forum » Microsoft Windows XP » General XP issues or comments
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Arrow keys not working with Agent



 
 
Thread Tools Display Modes
  #1  
Old May 2nd 21, 08:31 PM posted to microsoft.public.windowsxp.general
Shadow
external usenet poster
 
Posts: 1,638
Default Arrow keys not working with Agent

XP SP3
Forte Agent 3.3 and 1.93(freeware), same problem with both.

I click some text, but "miss" the right place.

I used to be able to use my arrow keys to move the mouse cursor up.
down, right or left to get to the place I wanted.
Now it scrolls the window.

The keys work in every other program I've tested - Ultraedit,
notepad++, palemoon(Newmoon) browser debuggers etc. so I don't think I
need a new keyboard.

I tried reloading an older copy of my registry = didn't work.
I tried checking the environment values, also win.ini, system.ini etc,
but nothing there.

I thought it might be a mouse driver error, so plugged in a nasty
little non-M$ mouse. No good.

Can't think of any other ways to debug this.

Can people here that use Agent check how their arrow keys work?
Maybe "scroll" is the default, and I deleted some hack I'd done a
decade ago.
TIA
--
Don't be evil - Google 2004
We have a new policy - Google 2012
Ads
  #2  
Old May 3rd 21, 06:59 AM posted to microsoft.public.windowsxp.general
Ralph Fox
external usenet poster
 
Posts: 474
Default Arrow keys not working with Agent

On Sun, 02 May 2021 16:31:55 -0300, Shadow wrote:

XP SP3
Forte Agent 3.3 and 1.93(freeware), same problem with both.

I click some text, but "miss" the right place.

I used to be able to use my arrow keys to move the mouse cursor up.
down, right or left to get to the place I wanted.
Now it scrolls the window.

The keys work in every other program I've tested - Ultraedit,
notepad++, palemoon(Newmoon) browser debuggers etc. so I don't think I
need a new keyboard.

I tried reloading an older copy of my registry = didn't work.
I tried checking the environment values, also win.ini, system.ini etc,
but nothing there.

I thought it might be a mouse driver error, so plugged in a nasty
little non-M$ mouse. No good.

Can't think of any other ways to debug this.

Can people here that use Agent check how their arrow keys work?
Maybe "scroll" is the default, and I deleted some hack I'd done a
decade ago.
TIA



Look near the right-hand end of the status bar for a "SCRL" indicator.
Press the Scroll Lock key on your keyboard to turn off the "SCRL" indicator.

Each pane has its own separate "SCRL" indicator. Make sure they are all
turned off.

Also see...

1) The Agent 3.3 help file: Help Index Scroll Lock behavior

2) The Agent Newsreader FAQ: "The arrow keys don't move the selection, they scroll"
https://web.archive.org/web/20200627063700/http://www.forteinc.com/agent/faq.php#1CA377ECDB92AB2C85256C1F005A6C02


If your computer does not appear to have a Scroll Lock key, check the
manual for your computer. On mine, the Scroll Lock key is Fn+C.


--
Kind regards
Ralph

BMP Unicode Test: ☕️☀️☺️
SMP Unicode Test: 🍵️🌞️😊️
  #3  
Old May 3rd 21, 02:30 PM posted to microsoft.public.windowsxp.general
Shadow
external usenet poster
 
Posts: 1,638
Default Arrow keys not working with Agent

On Mon, 03 May 2021 17:59:08 +1200, Ralph Fox
wrote:

On Sun, 02 May 2021 16:31:55 -0300, Shadow wrote:

XP SP3
Forte Agent 3.3 and 1.93(freeware), same problem with both.

I click some text, but "miss" the right place.

I used to be able to use my arrow keys to move the mouse cursor up.
down, right or left to get to the place I wanted.
Now it scrolls the window.

The keys work in every other program I've tested - Ultraedit,
notepad++, palemoon(Newmoon) browser debuggers etc. so I don't think I
need a new keyboard.

I tried reloading an older copy of my registry = didn't work.
I tried checking the environment values, also win.ini, system.ini etc,
but nothing there.

I thought it might be a mouse driver error, so plugged in a nasty
little non-M$ mouse. No good.

Can't think of any other ways to debug this.

Can people here that use Agent check how their arrow keys work?
Maybe "scroll" is the default, and I deleted some hack I'd done a
decade ago.
TIA



Look near the right-hand end of the status bar for a "SCRL" indicator.
Press the Scroll Lock key on your keyboard to turn off the "SCRL" indicator.

Each pane has its own separate "SCRL" indicator. Make sure they are all
turned off.

Also see...

1) The Agent 3.3 help file: Help Index Scroll Lock behavior

2) The Agent Newsreader FAQ: "The arrow keys don't move the selection, they scroll"
https://web.archive.org/web/20200627063700/http://www.forteinc.com/agent/faq.php#1CA377ECDB92AB2C85256C1F005A6C02


If your computer does not appear to have a Scroll Lock key, check the
manual for your computer. On mine, the Scroll Lock key is Fn+C.


Weird. SCROLL LOCK was turned ON in Agent. With the SCROLL
LOCK keyboard light OFF.
I pressed the keyboard SCROLL LOCK key, and Agent went back
to it's "normal behavior". Closed Agent, hit SCROLL LOCK to turn it
OFF, opened Agent again and the "normal behavior" is still there.

A before and after comparison of agent.ini showed

[Message]
ScrollLock=1

Changed to

[Message]
ScrollLock=0

There were two more ScrollLock entries that needed
editing.under [Browser] and [Article].

The setting is only written when Agent is closed. Hence the
setting is "sticky".
Haven't had my lenses replaced for ages due to the COVID
pandemic, and am missing the target with my mouse very frequently.
Marked as "solved".
TY for pointing me in the right direction. I'm happy.
[]'s


--
Don't be evil - Google 2004
We have a new policy - Google 2012
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off






All times are GMT +1. The time now is 05:58 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright 2004-2022 PCbanter.
The comments are property of their posters.