A Windows XP help forum. PCbanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » PCbanter forum » Microsoft Windows XP » Customizing Windows XP
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

non-Unicode programs on user account [Win XP Pro]



 
 
Thread Tools Display Modes
  #1  
Old December 12th 10, 01:01 PM posted to microsoft.public.windowsxp.customize
gordom
external usenet poster
 
Posts: 1
Default non-Unicode programs on user account [Win XP Pro]

Hello everyone,
I hope this is a right place for my question. I was searching the net for the
answer on this problem for hours but I didn't find anything useful. You are my
last resort guys :-).
I'm using a localized version of XP Professional with SP3. I have 2 accounts:
one with the admin rights and a second one with restricted user privileges
(it's
used for every day work). The problem, I'm facing now, concerns non-Unicode
programs run under restricted user account. Menus in these applications are
not
displayed properly (they are full of hashes). The problem doesn't occur on the
admin account. The advanced properties of Regional and Language Options are
set
except "Apply all settings to the current user account and to the default
user profile" option. This one can't be selected permanently - each time
I
start the Regional and Language Options applet this option turns unchecked.
I tried the following:

1. I changed the user account into an admin type temporally and started
applications.
2. I ran these applications on user account but with admin privileges (Run as
command).
3. I created a brand new admin account and ran the programs.

Non of them helped (even a third one???). The only way to use these
applications
with correct menus is to run them on the admin account that was set as a first
account during an operating system setup process.
Any clues what's wrong? Thanks in advance for all your help.
Regards,
gordom
Ads
  #2  
Old December 12th 10, 06:57 PM posted to microsoft.public.windowsxp.customize
Barry Schwarz[_2_]
external usenet poster
 
Posts: 373
Default non-Unicode programs on user account [Win XP Pro]

On Sun, 12 Dec 2010 07:01:20 -0600, gordom
wrote:

snip

You might want to learn how to crosspost instead of multiposting
copies of the same message to different newsgroups.

--
Remove del for email
  #3  
Old December 13th 10, 11:04 AM posted to microsoft.public.windowsxp.customize
Tim Meddick[_3_]
external usenet poster
 
Posts: 1,020
Default non-Unicode programs on user account [Win XP Pro]

Try transposing the settings that are changed in the CURRENT_USER part of
the registry (re; your language options) to the USERS\.Default User hive.

(if you can be bothered)

Using the free registry detective tool - "Reg Shot" - you can discover just
which settings are changed after changing the in the Regional Options....

Otherwise - if you can't be bothered to learn how to do all that stuff -
it's probably the case that, if you abandon your user account and create a
brand new one - that all will be well with it!!

==

Cheers, Tim Meddick, Peckham, London. :-)




"gordom" wrote in message
...
Hello everyone,
I hope this is a right place for my question. I was searching the net for
the
answer on this problem for hours but I didn't find anything useful. You
are my
last resort guys :-).
I'm using a localized version of XP Professional with SP3. I have 2
accounts:
one with the admin rights and a second one with restricted user
privileges
(it's
used for every day work). The problem, I'm facing now, concerns
non-Unicode
programs run under restricted user account. Menus in these applications
are
not
displayed properly (they are full of hashes). The problem doesn't occur
on the
admin account. The advanced properties of Regional and Language Options
are
set
except "Apply all settings to the current user account and to the
default
user profile" option. This one can't be selected permanently - each
time
I
start the Regional and Language Options applet this option turns
unchecked.
I tried the following:

1. I changed the user account into an admin type temporally and started
applications.
2. I ran these applications on user account but with admin privileges
(Run as
command).
3. I created a brand new admin account and ran the programs.

Non of them helped (even a third one???). The only way to use these
applications
with correct menus is to run them on the admin account that was set as a
first
account during an operating system setup process.
Any clues what's wrong? Thanks in advance for all your help.
Regards,
gordom


  #4  
Old December 13th 10, 05:29 PM posted to microsoft.public.windowsxp.customize
gordom[_2_]
external usenet poster
 
Posts: 2
Default non-Unicode programs on user account [Win XP Pro]

W dniu 2010-12-12 19:57, Barry Schwarz pisze:
On Sun, 12 Dec 2010 07:01:20 -0600,
wrote:

snip

You might want to learn how to crosspost instead of multiposting
copies of the same message to different newsgroups.


Crossposting nor multiposting wasn't my intention. I had an access here
via web interface of some internet forum (till your post I didn't even
know that this is a Usenet group). Unfortunately something went wrong
during editing and my post was sent twice. Sorry for that.
  #5  
Old December 14th 10, 10:57 PM posted to microsoft.public.windowsxp.customize
gordom[_2_]
external usenet poster
 
Posts: 2
Default non-Unicode programs on user account [Win XP Pro]

W dniu 2010-12-13 12:04, Tim Meddick pisze:
Try transposing the settings that are changed in the CURRENT_USER part
of the registry (re; your language options) to the USERS\.Default User
hive.

(if you can be bothered)

Using the free registry detective tool - "Reg Shot" - you can discover
just which settings are changed after changing the in the Regional
Options....

Otherwise - if you can't be bothered to learn how to do all that stuff -
it's probably the case that, if you abandon your user account and create
a brand new one - that all will be well with it!!

==

Cheers, Tim Meddick, Peckham, London. :-)


Hi,
Thank you very much for your replay.

Being logged in as administrator:

1. I compared a language settings in both CURRENT_USER and
USERS\.Default User hives (i.e Control Panel\International and also,
just for secure, \Keyboard Layout and \Control Panel\Keyboard). In all
hives values seems to be the same. Nevertheless, according to your
advice, I transposed these keys from CURRENT_USER to USERS\.Default
User. It didn't help at all.

2. Using RegShot I tried to spot what values are modified when I changed
language for non-unicode programs (when language is changed computer has
to be restarted). However RegShot points to dozen of values that were
modified during this process, non of them refer to CURRENT_USER hive.

3. I created a brand new admin account. It didn't solve the problem.

The problem still persist . I don't have my language fonts in programs
menus started under limited user account. I can't select "Apply all
settings to the current user account and to the default user profile"
option of Regional and Language applet permanently. When the applet is
restarted this option turns to unchecked (regards admin account).

Any other clues?
Regards,
gordom
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off






All times are GMT +1. The time now is 03:21 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 PCbanter.
The comments are property of their posters.