A Windows XP help forum. PCbanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » PCbanter forum » Microsoft Windows XP » Customizing Windows XP
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

How to set NOTEPAD to save to UNICODE as default



 
 
Thread Tools Display Modes
  #1  
Old April 26th 07, 10:26 PM posted to microsoft.public.windowsxp.customize
*rain*drops*
external usenet poster
 
Posts: 26
Default How to set NOTEPAD to save to UNICODE as default

I guess the title says it: In XP, how do I set NOTEPAD to save to UNICODE
as default. I posted a similar query and recieved just one response,
recommending me to get a different program. I want to just tweak NOTEPAD,
through registry edits or whatever.

How do I do that?

--

*rain*drops*




Ads
  #2  
Old April 27th 07, 01:04 AM posted to microsoft.public.windowsxp.customize
RobertVA
external usenet poster
 
Posts: 386
Default How to set NOTEPAD to save to UNICODE as default

*rain*drops* wrote:
I guess the title says it: In XP, how do I set NOTEPAD to save to UNICODE
as default. I posted a similar query and recieved just one response,
recommending me to get a different program. I want to just tweak NOTEPAD,
through registry edits or whatever.

How do I do that?


Have you tried saving a blank file in UNICODE format and double clicking
a shortcut leading to that file instead of starting Notepad with the
normal Notepad application shortcut?

There is a "IfCharset" key with the value of 0 in the
\HKEY_CURRENT_USER\Software\Microsoft\Notepad section of the registry. I
don't know what effect changing that key would have. That key is
duplicated in another part of the registry too (do a search). CAUTION:
experimenting with registry entries could have serious and unwanted
effects on your applications and operating system.
  #3  
Old June 26th 13, 05:14 PM posted to microsoft.public.windowsxp.customize
tazosmr
external usenet poster
 
Posts: 1
Default How to set NOTEPAD to save to UNICODE as default

*rain*drops* wrote on 04/26/2007 17:26 ET :
I guess the title says it: In XP, how do I set NOTEPAD to save to UNICODE
as default. I posted a similar query and recieved just one response,
recommending me to get a different program. I want to just tweak NOTEPAD,
through registry edits or whatever.

How do I do that?


*rain*drops*

Just install this Notepad-Unicoder file(
http://otaxi.ge/programebi/notepadunicodireba.zip ) and fron now, your text
files will be automatically created with default Unicode(UTF8) text.
  #4  
Old January 25th 14, 08:50 PM posted to microsoft.public.windowsxp.customize
No_Name
external usenet poster
 
Posts: 1
Default How to set NOTEPAD to save to UNICODE as default

On Friday, 27 April 2007 02:26:35 UTC+5, *rain*drops* wrote:
I guess the title says it: In XP, how do I set NOTEPAD to save to UNICODE
as default. I posted a similar query and recieved just one response,
recommending me to get a different program. I want to just tweak NOTEPAD,
through registry edits or whatever.

How do I do that?

--

*rain*drops*


SET NOTEPAD TO SAVE IN UNICODE BY DEFAULT
=========================================

1. Right click - New - Text Document
2. Open "New Text Document.txt". Do NOT type anything!
3. Go to "File - Save As... " and choose UniCode under "Encoding:", press "Save" and overwrite existing file. Close the file.
4. Rename "New Text Document.txt" to "UniCode.txt"
5. Copy "UniCode.txt" to "C:\WINDOWS\SHELLNEW"
6. Open Regedit and Navigate to HKEY_CLASSES_ROOT\.txt\ShellNew
7. Right click in the right window - New - "String Value" and rename it to "FileName".
8. Double click on "FileName" and put "UniCode.txt" into "Value Data".
9. press OK It's finished.

Test it: Create new .txt document (Right click - New - Text Document). Open it and go to "File - Save As... " and see that encoding is set by

default to UniCode . :-)
  #5  
Old May 14th 15, 05:30 AM posted to microsoft.public.windowsxp.customize
No_Name
external usenet poster
 
Posts: 1
Default How to set NOTEPAD to save to UNICODE as default

On Saturday, January 25, 2014 at 9:50:31 PM UTC+2, wrote:
On Friday, 27 April 2007 02:26:35 UTC+5, *rain*drops* wrote:
I guess the title says it: In XP, how do I set NOTEPAD to save to UNICODE
as default. I posted a similar query and recieved just one response,
recommending me to get a different program. I want to just tweak NOTEPAD,
through registry edits or whatever.

How do I do that?

--

*rain*drops*


SET NOTEPAD TO SAVE IN UNICODE BY DEFAULT
=========================================

1. Right click - New - Text Document
2. Open "New Text Document.txt". Do NOT type anything!
3. Go to "File - Save As... " and choose UniCode under "Encoding:", press "Save" and overwrite existing file. Close the file.
4. Rename "New Text Document.txt" to "UniCode.txt"
5. Copy "UniCode.txt" to "C:\WINDOWS\SHELLNEW"
6. Open Regedit and Navigate to HKEY_CLASSES_ROOT\.txt\ShellNew
7. Right click in the right window - New - "String Value" and rename it to "FileName".
8. Double click on "FileName" and put "UniCode.txt" into "Value Data".
9. press OK It's finished.

Test it: Create new .txt document (Right click - New - Text Document). Open it and go to "File - Save As... " and see that encoding is set by

default to UniCode . :-)


Thank you
it worked like magic
  #6  
Old March 9th 16, 04:21 PM posted to microsoft.public.windowsxp.customize
No_Name
external usenet poster
 
Posts: 1
Default How to set NOTEPAD to save to UNICODE as default

awesome fix, Thanks
  #7  
Old July 24th 16, 08:25 AM posted to microsoft.public.windowsxp.customize
No_Name
external usenet poster
 
Posts: 1
Default How to set NOTEPAD to save to UNICODE as default

I have Windows 10.
This works only for Right click - New - Text Document.
If I open Notepad from the Start menu, it opens with the encoding ANSI as default.
Therefore, I think, it is easier to have the New Text Document.txt on the Desktop and open it to write any Unicode document, instead of changing the registry entries.
  #8  
Old August 12th 16, 12:47 PM posted to microsoft.public.windowsxp.customize
No_Name
external usenet poster
 
Posts: 1
Default How to set NOTEPAD to save to UNICODE as default

On Saturday, January 25, 2014 at 9:50:31 PM UTC+2, wrote:
On Friday, 27 April 2007 02:26:35 UTC+5, *rain*drops* wrote:
I guess the title says it: In XP, how do I set NOTEPAD to save to UNICODE
as default. I posted a similar query and recieved just one response,
recommending me to get a different program. I want to just tweak NOTEPAD,
through registry edits or whatever.

How do I do that?

--

*rain*drops*


SET NOTEPAD TO SAVE IN UNICODE BY DEFAULT
=========================================

1. Right click - New - Text Document
2. Open "New Text Document.txt". Do NOT type anything!
3. Go to "File - Save As... " and choose UniCode under "Encoding:", press "Save" and overwrite existing file. Close the file.
4. Rename "New Text Document.txt" to "UniCode.txt"
5. Copy "UniCode.txt" to "C:\WINDOWS\SHELLNEW"
6. Open Regedit and Navigate to HKEY_CLASSES_ROOT\.txt\ShellNew
7. Right click in the right window - New - "String Value" and rename it to "FileName".
8. Double click on "FileName" and put "UniCode.txt" into "Value Data".
9. press OK It's finished.

Test it: Create new .txt document (Right click - New - Text Document). Open it and go to "File - Save As... " and see that encoding is set by

default to UniCode . :-)


Thanks
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off






All times are GMT +1. The time now is 02:23 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2004-2017 PCbanter.
The comments are property of their posters.