A Windows XP help forum. PCbanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » PCbanter forum » Microsoft Windows XP » Printing and Faxing with Windows XP
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Epson Stylus photo R300 usb printer problem



 
 
Thread Tools Display Modes
  #1  
Old April 1st 06, 05:37 PM posted to microsoft.public.windowsxp.print_fax
external usenet poster
 
Posts: n/a
Default Epson Stylus photo R300 usb printer problem

Spec: win XP SP2, Athlon 2800+, 1 gig DDR Ram, 200gig HD

I've recently developed a problem with my Epson Stylus Photo R300 printer
which I cannot solve. When I turn the printer on I get the new hadrware
detected wizard start up, and I am told that there is a problem with USB
Printer support. The printer is either recognised as a USB mass storage
device, or not recognised at all. I've tried uninstalling and reinstalling
the driver. I've downloaded the latest drivers from the epson website, but
get the same problem.

I've tried removing the printer from the 'printers and faxes' option of the
start menu. I also clicked File and purged the R300 driver from my system. I
then unplugged the printer from the computer, rebooted and tried reinstalling
the driver. Same problem !

Any suggestions would be gratefully received.
Ads
  #2  
Old April 1st 06, 06:36 PM posted to microsoft.public.windowsxp.print_fax
external usenet poster
 
Posts: n/a
Default Epson Stylus photo R300 usb printer problem

It is a removable drive if it has a card reader in it....

I'd try a complete uninstall then reinstall...

http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
and then
http://www.coribright.com/windows/Article%20One.htm
--
Cari (MS-MVP)
Printing & Imaging
http://www.coribright.com/windows



"Fr J" wrote in message
...
Spec: win XP SP2, Athlon 2800+, 1 gig DDR Ram, 200gig HD

I've recently developed a problem with my Epson Stylus Photo R300 printer
which I cannot solve. When I turn the printer on I get the new hadrware
detected wizard start up, and I am told that there is a problem with USB
Printer support. The printer is either recognised as a USB mass storage
device, or not recognised at all. I've tried uninstalling and reinstalling
the driver. I've downloaded the latest drivers from the epson website, but
get the same problem.

I've tried removing the printer from the 'printers and faxes' option of
the
start menu. I also clicked File and purged the R300 driver from my system.
I
then unplugged the printer from the computer, rebooted and tried
reinstalling
the driver. Same problem !

Any suggestions would be gratefully received.



  #3  
Old April 1st 06, 08:00 PM posted to microsoft.public.windowsxp.print_fax
external usenet poster
 
Posts: n/a
Default Epson Stylus photo R300 usb printer problem

Yes it has a card reader - no cards in it at the moment.

do you mean a complete uninstall of XP or just the printer?

I've tried a complete uninstall of the printer. I then unplugged the printer
and USB cable - reinstalled the driver and follwed the manufacturer's
instalation procedure. As soon as I plug in the USB cable and switch on the
printer the 'new Hardware Wizard' begins and identifes the printer as
'unknown device' and the installation fails to ercognise the printer.

Any suggestions what to try next?


"Cari (MS-MVP)" wrote:

It is a removable drive if it has a card reader in it....

I'd try a complete uninstall then reinstall...

http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
and then
http://www.coribright.com/windows/Article%20One.htm
--
Cari (MS-MVP)
Printing & Imaging
http://www.coribright.com/windows



"Fr J" wrote in message
...
Spec: win XP SP2, Athlon 2800+, 1 gig DDR Ram, 200gig HD

I've recently developed a problem with my Epson Stylus Photo R300 printer
which I cannot solve. When I turn the printer on I get the new hadrware
detected wizard start up, and I am told that there is a problem with USB
Printer support. The printer is either recognised as a USB mass storage
device, or not recognised at all. I've tried uninstalling and reinstalling
the driver. I've downloaded the latest drivers from the epson website, but
get the same problem.

I've tried removing the printer from the 'printers and faxes' option of
the
start menu. I also clicked File and purged the R300 driver from my system.
I
then unplugged the printer from the computer, rebooted and tried
reinstalling
the driver. Same problem !

Any suggestions would be gratefully received.




  #4  
Old April 1st 06, 08:32 PM posted to microsoft.public.windowsxp.print_fax
external usenet poster
 
Posts: n/a
Default Epson Stylus photo R300 usb printer problem

You should install the software BEFORE connecting the printer to the PC...
exactly as set out in the second link I already gave you.
--
Cari (MS-MVP) Windows Client - Printing & Imaging
www.coribright.com/Windows


"Fr J" wrote in message
...
Yes it has a card reader - no cards in it at the moment.

do you mean a complete uninstall of XP or just the printer?

I've tried a complete uninstall of the printer. I then unplugged the
printer
and USB cable - reinstalled the driver and follwed the manufacturer's
instalation procedure. As soon as I plug in the USB cable and switch on
the
printer the 'new Hardware Wizard' begins and identifes the printer as
'unknown device' and the installation fails to ercognise the printer.

Any suggestions what to try next?


"Cari (MS-MVP)" wrote:

It is a removable drive if it has a card reader in it....

I'd try a complete uninstall then reinstall...

http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
and then
http://www.coribright.com/windows/Article%20One.htm
--
Cari (MS-MVP)
Printing & Imaging
http://www.coribright.com/windows



"Fr J" wrote in message
...
Spec: win XP SP2, Athlon 2800+, 1 gig DDR Ram, 200gig HD

I've recently developed a problem with my Epson Stylus Photo R300
printer
which I cannot solve. When I turn the printer on I get the new hadrware
detected wizard start up, and I am told that there is a problem with
USB
Printer support. The printer is either recognised as a USB mass storage
device, or not recognised at all. I've tried uninstalling and
reinstalling
the driver. I've downloaded the latest drivers from the epson website,
but
get the same problem.

I've tried removing the printer from the 'printers and faxes' option of
the
start menu. I also clicked File and purged the R300 driver from my
system.
I
then unplugged the printer from the computer, rebooted and tried
reinstalling
the driver. Same problem !

Any suggestions would be gratefully received.






  #5  
Old April 1st 06, 09:24 PM posted to microsoft.public.windowsxp.print_fax
external usenet poster
 
Posts: n/a
Default Epson Stylus photo R300 usb printer problem

I di follow both links in the order you gave them.

I ran cleanspl.exe and removed any remnants of printer drivers.

I then follwed the instruction given in the second link - exactly as printed.

I downloaded the latest drivers from the Epsom website.

I rebooted and installed the software BEFORE commecting the printer to my PC

At the appropriate prompt I plugged in the USB cable, turned on the printer
(the only USB device connected to my compter)

And GUESS WHAT !!!!! It still didn't work.

The New Hardware Wizard immediately recognised the printer as a 'USB
Composite Device' which it then told me wasn't working properly.

The Epson driver failed to recognise the USB post and installed the printer
to LPT 1. If I then switch this to USB port 1 in the printer properties for
the R300 printer it still won't print via USB

Any suggestions as to what I should try next?

Thanks

"Cari (MS-MVP)" wrote:

You should install the software BEFORE connecting the printer to the PC...
exactly as set out in the second link I already gave you.
--
Cari (MS-MVP) Windows Client - Printing & Imaging
www.coribright.com/Windows


"Fr J" wrote in message
...
Yes it has a card reader - no cards in it at the moment.

do you mean a complete uninstall of XP or just the printer?

I've tried a complete uninstall of the printer. I then unplugged the
printer
and USB cable - reinstalled the driver and follwed the manufacturer's
instalation procedure. As soon as I plug in the USB cable and switch on
the
printer the 'new Hardware Wizard' begins and identifes the printer as
'unknown device' and the installation fails to ercognise the printer.

Any suggestions what to try next?


"Cari (MS-MVP)" wrote:

It is a removable drive if it has a card reader in it....

I'd try a complete uninstall then reinstall...

http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
and then
http://www.coribright.com/windows/Article%20One.htm
--
Cari (MS-MVP)
Printing & Imaging
http://www.coribright.com/windows



"Fr J" wrote in message
...
Spec: win XP SP2, Athlon 2800+, 1 gig DDR Ram, 200gig HD

I've recently developed a problem with my Epson Stylus Photo R300
printer
which I cannot solve. When I turn the printer on I get the new hadrware
detected wizard start up, and I am told that there is a problem with
USB
Printer support. The printer is either recognised as a USB mass storage
device, or not recognised at all. I've tried uninstalling and
reinstalling
the driver. I've downloaded the latest drivers from the epson website,
but
get the same problem.

I've tried removing the printer from the 'printers and faxes' option of
the
start menu. I also clicked File and purged the R300 driver from my
system.
I
then unplugged the printer from the computer, rebooted and tried
reinstalling
the driver. Same problem !

Any suggestions would be gratefully received.






  #6  
Old April 2nd 06, 12:12 AM posted to microsoft.public.windowsxp.print_fax
external usenet poster
 
Posts: n/a
Default Epson Stylus photo R300 usb printer problem

I currently use an Epson R300M (Just has an optional color LCD, no other
differences from an R300.)

Uninstall The R300 and use Epsons clean up utility. Check the registry for
any additional Epson R300 entries that were not removed. Use the current
version of the driver available on the Epson website, or down load the
appropriate patches. (Or both)
Uninstall the USB subsystem if you do not use a USB keyboard and mouse.
Reboot with the printer disconnected. Expect to have the XP install CD(s)
available (if needed). Usually the CD(s) are not needed. Allow the USB
system to be detected by Plug & Pray, and the needed drivers installed. (If
you have an uncommon MBD support chipset, you may need to install chipset
specific drivers for the USB subsystem. If so, follow whatever proceedure is
appropriate for your MBD.

Once the USB port and controller drivers are added and recognized, and the
system is stable, Reboot.

Install the R300 drivers, and connect the printer per Epsons instructions
when told to do so.

Normally,. this cures the problem you mentioned.

My installed driver version 5.51
Port USB001 Virtual Printer port for USB EPSON Stylus Photo R300 Series
Bi directional printing is enabled.

An oddity is that the name for the Epson memory card slot and the drive
letter may change. Tis seems to be because a Brother all in one printer is
installed, and also has a built in card reader.


"Fr J" wrote in message
...
I di follow both links in the order you gave them.

I ran cleanspl.exe and removed any remnants of printer drivers.

I then follwed the instruction given in the second link - exactly as

printed.

I downloaded the latest drivers from the Epsom website.

I rebooted and installed the software BEFORE commecting the printer to my

PC

At the appropriate prompt I plugged in the USB cable, turned on the

printer
(the only USB device connected to my compter)

And GUESS WHAT !!!!! It still didn't work.

The New Hardware Wizard immediately recognised the printer as a 'USB
Composite Device' which it then told me wasn't working properly.

The Epson driver failed to recognise the USB post and installed the

printer
to LPT 1. If I then switch this to USB port 1 in the printer properties

for
the R300 printer it still won't print via USB

Any suggestions as to what I should try next?

Thanks

"Cari (MS-MVP)" wrote:

You should install the software BEFORE connecting the printer to the

PC...
exactly as set out in the second link I already gave you.
--
Cari (MS-MVP) Windows Client - Printing & Imaging
www.coribright.com/Windows


"Fr J" wrote in message
...
Yes it has a card reader - no cards in it at the moment.

do you mean a complete uninstall of XP or just the printer?

I've tried a complete uninstall of the printer. I then unplugged the
printer
and USB cable - reinstalled the driver and follwed the manufacturer's
instalation procedure. As soon as I plug in the USB cable and switch

on
the
printer the 'new Hardware Wizard' begins and identifes the printer as
'unknown device' and the installation fails to ercognise the printer.

Any suggestions what to try next?


"Cari (MS-MVP)" wrote:

It is a removable drive if it has a card reader in it....

I'd try a complete uninstall then reinstall...

http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
and then
http://www.coribright.com/windows/Article%20One.htm
--
Cari (MS-MVP)
Printing & Imaging
http://www.coribright.com/windows



"Fr J" wrote in message
...
Spec: win XP SP2, Athlon 2800+, 1 gig DDR Ram, 200gig HD

I've recently developed a problem with my Epson Stylus Photo R300
printer
which I cannot solve. When I turn the printer on I get the new

hadrware
detected wizard start up, and I am told that there is a problem

with
USB
Printer support. The printer is either recognised as a USB mass

storage
device, or not recognised at all. I've tried uninstalling and
reinstalling
the driver. I've downloaded the latest drivers from the epson

website,
but
get the same problem.

I've tried removing the printer from the 'printers and faxes'

option of
the
start menu. I also clicked File and purged the R300 driver from my
system.
I
then unplugged the printer from the computer, rebooted and tried
reinstalling
the driver. Same problem !

Any suggestions would be gratefully received.








  #7  
Old April 3rd 06, 10:45 AM posted to microsoft.public.windowsxp.print_fax
external usenet poster
 
Posts: n/a
Default Epson Stylus photo R300 usb printer problem

Sounds like my problem, which i have solved on my laptop but not my desktop.
That is because all usb ports on the pc are "hubs" rather than a direct
connection to/from the printer. If you have such a" dedicated" usb port,
uninstall everything to do with the printer,turn off pc,connect printer both
power on and usb, turn on pc,cancel any 'found new hardware' screens and
install the printer again. good luck.

"Chuck" wrote:

I currently use an Epson R300M (Just has an optional color LCD, no other
differences from an R300.)

Uninstall The R300 and use Epsons clean up utility. Check the registry for
any additional Epson R300 entries that were not removed. Use the current
version of the driver available on the Epson website, or down load the
appropriate patches. (Or both)
Uninstall the USB subsystem if you do not use a USB keyboard and mouse.
Reboot with the printer disconnected. Expect to have the XP install CD(s)
available (if needed). Usually the CD(s) are not needed. Allow the USB
system to be detected by Plug & Pray, and the needed drivers installed. (If
you have an uncommon MBD support chipset, you may need to install chipset
specific drivers for the USB subsystem. If so, follow whatever proceedure is
appropriate for your MBD.

Once the USB port and controller drivers are added and recognized, and the
system is stable, Reboot.

Install the R300 drivers, and connect the printer per Epsons instructions
when told to do so.

Normally,. this cures the problem you mentioned.

My installed driver version 5.51
Port USB001 Virtual Printer port for USB EPSON Stylus Photo R300 Series
Bi directional printing is enabled.

An oddity is that the name for the Epson memory card slot and the drive
letter may change. Tis seems to be because a Brother all in one printer is
installed, and also has a built in card reader.


"Fr J" wrote in message
...
I di follow both links in the order you gave them.

I ran cleanspl.exe and removed any remnants of printer drivers.

I then follwed the instruction given in the second link - exactly as

printed.

I downloaded the latest drivers from the Epsom website.

I rebooted and installed the software BEFORE commecting the printer to my

PC

At the appropriate prompt I plugged in the USB cable, turned on the

printer
(the only USB device connected to my compter)

And GUESS WHAT !!!!! It still didn't work.

The New Hardware Wizard immediately recognised the printer as a 'USB
Composite Device' which it then told me wasn't working properly.

The Epson driver failed to recognise the USB post and installed the

printer
to LPT 1. If I then switch this to USB port 1 in the printer properties

for
the R300 printer it still won't print via USB

Any suggestions as to what I should try next?

Thanks

"Cari (MS-MVP)" wrote:

You should install the software BEFORE connecting the printer to the

PC...
exactly as set out in the second link I already gave you.
--
Cari (MS-MVP) Windows Client - Printing & Imaging
www.coribright.com/Windows


"Fr J" wrote in message
...
Yes it has a card reader - no cards in it at the moment.

do you mean a complete uninstall of XP or just the printer?

I've tried a complete uninstall of the printer. I then unplugged the
printer
and USB cable - reinstalled the driver and follwed the manufacturer's
instalation procedure. As soon as I plug in the USB cable and switch

on
the
printer the 'new Hardware Wizard' begins and identifes the printer as
'unknown device' and the installation fails to ercognise the printer.

Any suggestions what to try next?


"Cari (MS-MVP)" wrote:

It is a removable drive if it has a card reader in it....

I'd try a complete uninstall then reinstall...

http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
and then
http://www.coribright.com/windows/Article%20One.htm
--
Cari (MS-MVP)
Printing & Imaging
http://www.coribright.com/windows



"Fr J" wrote in message
...
Spec: win XP SP2, Athlon 2800+, 1 gig DDR Ram, 200gig HD

I've recently developed a problem with my Epson Stylus Photo R300
printer
which I cannot solve. When I turn the printer on I get the new

hadrware
detected wizard start up, and I am told that there is a problem

with
USB
Printer support. The printer is either recognised as a USB mass

storage
device, or not recognised at all. I've tried uninstalling and
reinstalling
the driver. I've downloaded the latest drivers from the epson

website,
but
get the same problem.

I've tried removing the printer from the 'printers and faxes'

option of
the
start menu. I also clicked File and purged the R300 driver from my
system.
I
then unplugged the printer from the computer, rebooted and tried
reinstalling
the driver. Same problem !

Any suggestions would be gratefully received.









 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
XP Does Not Create A USB Virtual Device When Installing Epson Photo R300 Student01 Printing and Faxing with Windows XP 2 March 10th 06 06:59 PM
Default Printer won't stay put.... Jim Wood Printing and Faxing with Windows XP 17 February 28th 06 02:41 PM
Epson Stylus Color 600 Printer Driver XP Home Edition Sam Printing and Faxing with Windows XP 9 November 11th 05 12:54 AM
Networking with XP pro papaul Networking and the Internet with Windows XP 36 November 19th 04 12:09 AM
XP won't print, WIN9X will boders67 Printing and Faxing with Windows XP 6 September 18th 04 07:09 AM






All times are GMT +1. The time now is 09:05 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 PCbanter.
The comments are property of their posters.