A Windows XP help forum. PCbanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » PCbanter forum » Microsoft Windows XP » Windows XP Help and Support
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Explorer filename sorting problem - NoStrCmpLogical already present



 
 
Thread Tools Display Modes
  #1  
Old March 26th 16, 07:58 PM posted to microsoft.public.windowsxp.help_and_support
R.Wieser
external usenet poster
 
Posts: 465
Default Explorer filename sorting problem - NoStrCmpLogical already present

Hello All,

My file explorer seems to have trouble sorting filenames in an intuitive
way. Just look at the below (listing generated using "dir /one 60.*", but
the same order appears in Explorer)

60.00.00.32.dds
60.00.00.32.msh
60.00.00.32.nif
60.00.32.32.dds
60.00.-32.32.dds
60.00.32.32.msh
60.00.-32.32.msh
60.00.32.32.nif
60.00.-32.32.nif

I would expect the "60.00.-30.*" entries to come first, followed by the
"60.00.00.*" and "60.00.32.*" groups.

Some time ago (years probably :-) ) I've added the NoStrCmpLogical setting,
and thought that it was fixed. But apperantly no such luck.

Does anyone know what is going on here -- or better yet, how to fix it ?

Regards,
Rudy Wieser



Ads
  #2  
Old March 27th 16, 03:44 AM posted to microsoft.public.windowsxp.help_and_support
JJ[_11_]
external usenet poster
 
Posts: 486
Default Explorer filename sorting problem - NoStrCmpLogical already present

On Sat, 26 Mar 2016 19:58:23 +0100, R.Wieser wrote:
Hello All,

My file explorer seems to have trouble sorting filenames in an intuitive
way. Just look at the below (listing generated using "dir /one 60.*", but
the same order appears in Explorer)

60.00.00.32.dds
60.00.00.32.msh
60.00.00.32.nif
60.00.32.32.dds
60.00.-32.32.dds
60.00.32.32.msh
60.00.-32.32.msh
60.00.32.32.nif
60.00.-32.32.nif

I would expect the "60.00.-30.*" entries to come first, followed by the
"60.00.00.*" and "60.00.32.*" groups.

Some time ago (years probably :-) ) I've added the NoStrCmpLogical setting,
and thought that it was fixed. But apperantly no such luck.

Does anyone know what is going on here -- or better yet, how to fix it ?

Regards,
Rudy Wieser


NoStrCmpLogical is a policy setting for (Windows) Explorer only.
CMD is never affected and will always use binary compare for sorting.

https://support.microsoft.com/en-us/kb/319827
  #3  
Old March 27th 16, 09:35 AM posted to microsoft.public.windowsxp.help_and_support
R.Wieser
external usenet poster
 
Posts: 465
Default Explorer filename sorting problem - NoStrCmpLogical already present

JJ,

NoStrCmpLogical is a policy setting for (Windows) Explorer only.


Than is doubly remarkable that *both* show the same list ....

CMD is never affected and will always use binary compare for sorting.


Please, don't do that. You can see for yourself that it doesn't appear to
do so. :-(

https://support.microsoft.com/en-us/kb/319827


That page seems to have become outdated, as I was met with the (in)famous
"Try searching for what you need. This page doesn't exist." error message.

Regards,
Rudy Wieser


-- Origional message:
JJ schreef in berichtnieuws
...
On Sat, 26 Mar 2016 19:58:23 +0100, R.Wieser wrote:
Hello All,

My file explorer seems to have trouble sorting filenames in an intuitive
way. Just look at the below (listing generated using "dir /one 60.*",

but
the same order appears in Explorer)

60.00.00.32.dds
60.00.00.32.msh
60.00.00.32.nif
60.00.32.32.dds
60.00.-32.32.dds
60.00.32.32.msh
60.00.-32.32.msh
60.00.32.32.nif
60.00.-32.32.nif

I would expect the "60.00.-30.*" entries to come first, followed by the
"60.00.00.*" and "60.00.32.*" groups.

Some time ago (years probably :-) ) I've added the NoStrCmpLogical

setting,
and thought that it was fixed. But apperantly no such luck.

Does anyone know what is going on here -- or better yet, how to fix it ?

Regards,
Rudy Wieser


NoStrCmpLogical is a policy setting for (Windows) Explorer only.
CMD is never affected and will always use binary compare for sorting.

https://support.microsoft.com/en-us/kb/319827



  #4  
Old March 27th 16, 02:50 PM posted to microsoft.public.windowsxp.help_and_support
JJ[_11_]
external usenet poster
 
Posts: 486
Default Explorer filename sorting problem - NoStrCmpLogical already present

On Sun, 27 Mar 2016 10:35:50 +0200, R.Wieser wrote:
JJ,

NoStrCmpLogical is a policy setting for (Windows) Explorer only.


Than is doubly remarkable that *both* show the same list ....

CMD is never affected and will always use binary compare for sorting.


Please, don't do that. You can see for yourself that it doesn't appear to
do so. :-(

https://support.microsoft.com/en-us/kb/319827


That page seems to have become outdated, as I was met with the (in)famous
"Try searching for what you need. This page doesn't exist." error message.

Regards,
Rudy Wieser

-- Origional message:
JJ schreef in berichtnieuws
...
On Sat, 26 Mar 2016 19:58:23 +0100, R.Wieser wrote:
Hello All,

My file explorer seems to have trouble sorting filenames in an intuitive
way. Just look at the below (listing generated using "dir /one 60.*",

but
the same order appears in Explorer)

60.00.00.32.dds
60.00.00.32.msh
60.00.00.32.nif
60.00.32.32.dds
60.00.-32.32.dds
60.00.32.32.msh
60.00.-32.32.msh
60.00.32.32.nif
60.00.-32.32.nif

I would expect the "60.00.-30.*" entries to come first, followed by the
"60.00.00.*" and "60.00.32.*" groups.

Some time ago (years probably :-) ) I've added the NoStrCmpLogical

setting,
and thought that it was fixed. But apperantly no such luck.

Does anyone know what is going on here -- or better yet, how to fix it ?

Regards,
Rudy Wieser


See the cached page from Google using below Google search query:

cache:https://support.microsoft.com/en-us/kb/319827

Or use web archive.
  #5  
Old March 27th 16, 07:05 PM posted to microsoft.public.windowsxp.help_and_support
R.Wieser
external usenet poster
 
Posts: 465
Default Explorer filename sorting problem - NoStrCmpLogical already present

JJ,

See the cached page from Google using below Google search query:

cache:https://support.microsoft.com/en-us/kb/319827


Thanks, I can see the page now. Alas, it only describes the usage of
NoStrCmpLogical, which I have already applied.

Disabeling the setting and re-enabeling it (on both HKCU and HKLM brances)
does not seem to change anything on that folder.

And a funny thing is that it seems to do the same on the second column as it
does (as shown) on the third column. Almost as if it starts to sort on
extension first, only than on the filename. But that shows not to be the
case, as the first column is sorted in order (have more than just those 60.*
files). Rather odd.

Regards,
Rudy Wieser


-- Origional message:
JJ schreef in berichtnieuws
...
On Sun, 27 Mar 2016 10:35:50 +0200, R.Wieser wrote:
JJ,

NoStrCmpLogical is a policy setting for (Windows) Explorer only.


Than is doubly remarkable that *both* show the same list ....

CMD is never affected and will always use binary compare for sorting.


Please, don't do that. You can see for yourself that it doesn't appear

to
do so. :-(

https://support.microsoft.com/en-us/kb/319827


That page seems to have become outdated, as I was met with the

(in)famous
"Try searching for what you need. This page doesn't exist." error

message.

Regards,
Rudy Wieser

-- Origional message:
JJ schreef in berichtnieuws
...
On Sat, 26 Mar 2016 19:58:23 +0100, R.Wieser wrote:
Hello All,

My file explorer seems to have trouble sorting filenames in an

intuitive
way. Just look at the below (listing generated using "dir /one 60.*",

but
the same order appears in Explorer)

60.00.00.32.dds
60.00.00.32.msh
60.00.00.32.nif
60.00.32.32.dds
60.00.-32.32.dds
60.00.32.32.msh
60.00.-32.32.msh
60.00.32.32.nif
60.00.-32.32.nif

I would expect the "60.00.-30.*" entries to come first, followed by

the
"60.00.00.*" and "60.00.32.*" groups.

Some time ago (years probably :-) ) I've added the NoStrCmpLogical

setting,
and thought that it was fixed. But apperantly no such luck.

Does anyone know what is going on here -- or better yet, how to fix it

?

Regards,
Rudy Wieser


See the cached page from Google using below Google search query:

cache:
https://support.microsoft.com/en-us/kb/319827

Or use web archive.



 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off






All times are GMT +1. The time now is 03:05 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 PCbanter.
The comments are property of their posters.